WLAN-Probleme mit dem iMac Mitte 2011; Lösung

Eigentlich kaum zu glauben, aber auch im Jahre 2011 und bei einem Gerät im Wert von über 1500€ gibt es Probleme, die nicht existieren sollten. Es handelt sich um den aktuellen iMac, der mit recht vielen Routern/APs, darunter auch die FRITZ!Boxen, überhaupt nicht harmoniert. Der iMac verliert in unterschiedlichen Abständen die Verbindung zum Router, das AirPort-Icon in der Menubar bleibt aber unverändert und zeigt eine Verbindung an. Wahrscheinlich hängt dies an der WPA2-Authentifizierung, der iMac “vergisst” sozusagen den Schlüssel, dies kann man zumindest den Statusmeldungen der FRITZ!Box entnehmen.

Ich hatte schon mehrmals Kontakt mit AppleCare, die einen Hardware-Defekt ausschlossen (nachvollziehbar) und mir immer wieder sagten, dass diese Probleme untypisch seien und nicht oft beklagt würden. Die Support-Foren im Netz zeigen hier allerdings das Gegenteil, etliche Nutzer haben genau diese Probleme.

Die Fehlerbehebung kann wie folgt aussehen:

  • AirPort Extreme anschaffen, wobei ich sogar hiermit Probleme hatte. Hier war die Verbindung nach dem Aufwachen des iMac zum Teil enorm schwach und langsam
  • In der FRITZ!Box-Administrationsoberfläche (http://fritz.box oder 192.168.178.1) bei aktivierter Expertenansicht unter WLAN > Funkkanal die Option Für 300 Mbit/s optimierte Funkkanäle nutzen deaktivieren. Dies hat das Problem bei mir gelöst. Der Nachteil ist, dass die Verbindungsstärke geringer ist (bei mir ca. 120 MBit/s, mit der AirPort Extreme hatte ich bis zu 270 MBit/s).

Wer ist also Schuld? Apple. Es kann nicht sein, dass man bei solch einem Premium-Gerät die Kompatibilität nicht schafft und vor allem den in Deutschland am häufigsten verwendeten Router nicht ausgiebig testet. Im Übrigen hatte ich gehofft, dass OS X Lion den Fehler beheben würde, dies ist aber nicht der Fall. Apple kann nicht erwarten, dass jeder Haushalt in dem sich Apple-Geräte befinden über eine AirPort Extreme/Express verfügt.

Update 06.02.2012
Mit OS X 10.7.3 gibt es neue WLAN-Probleme (mittlerweile behoben). Mehr Infos dazu hier.

18 thoughts on “WLAN-Probleme mit dem iMac Mitte 2011; Lösung

  1. hallo toller tip hat meiner mac verehrerin super geholfen jetzt darf ich wieder mit 150mbit meine daten von rechner zu rechner ziehen um sie dann zu bearbeiten und sie kann facebook nutzen super toll danke apple und vielen ehrlichen dank herr wölm

  2. Ja, der Tipp war gut, bei mir läuft es seit der Umstellung vor ca. 24 Stunden problemlos.

    Und ich wollte schon das Gerät zu Gravis zurückbringen, weil AppleCare keinen Rat wusste.

    Danke.
    Walter

  3. Gleiches Problem hier, bin zufällig selbst auf die Lösung gekommen. Alle Geräte funktionierten mit den 300MBit-Kanälen, sogar das Macbook, nur eben der blöde iMac nicht – ärgerlich und mit Sicherheit ein Problem von Apples Seite. Nachbessern!

    • Ich bezweifle leider, dass Apple da weiter investigieren wird. Mir wurde damals von Apple mitgeteilt, dass AVM sich darum kümmern müsste und Apple selbst keine Inkompatibilitäten kennt und sich auch keine weiteren Nutzer mit ähnlichen Problemen melden würden.

      Dass das nicht der Fall ist, sieht man ja an der Resonanz dieses Posts. Ich habe jeden Tag 30 Besucher via Google, die explizit nach WLAN Problemen beim iMac in Zusammenhang mit der FRITZ!Box suchen.

  4. Tja, das hat wohl nicht nur mit der Fritzbox zu tun. Ich habe und hatte schon immer Apple Router und das Problem des Verbindungsabbruchs besteht auch bei meinem Imac. Nur: Alle andern Geräte funktionieren einwandfrei ! Iphone, Macbook, Ibook, zwei Windows-Notebooks. Also läuft da was im Imac nicht !!

  5. iMac Mai 2011. Ich konnte meinen iMac mit der der Fritzbox 6360 über Wlan gar nicht verbinden. Nachdem der Haken für die optimierten Funkkanäle raus war, war das kein Problem mehr. Windows 7 unter Bootcamp ist von diesem Phänomen nicht betroffen. Läßt man die Fritzbox im 5GHz Band funken, tritt dieses Problem auch nicht auf. Apple Support und Geniusbar sind ratlos. Scheinen sich wohl im Internet nicht zu informieren. Und Danke für den Tip!!!!!!!!

  6. Hatte das gleiche Problem.
    “WLAN > Funkkanal die Option Für 300 Mbit/s optimierte Funkkanäle nutzen deaktivieren” hat Problem behoben.
    Danke.

  7. Selbes Problem hier. Funkelnagelneuer iMac, von Anfang an Verbindungsabbrüche. Habe gleichzeitig ein MacBook Air gekauft, da habe ich keinerlei Probleme. Sowieso haben alle 5 Haushalts-PCs und 2 Smartphones keine Probleme. Nur der iMac… ich finde das zum kotzen.

  8. Auch von mir vielen Dank für die Lösung. Auch hier nagelneue Geräte, fritzbox iMac und diverese iPads Iphones und Windows PCs – alle bis auf den iMac laufen problemlos über die fritzbox. Devenitiv kein seltenes Problem – eher ein gewollter Fehler so das entnervte User einen AirPort Extrem kaufen, echt lahm von Apple.

  9. selbes bei meinem neuen Imac und Fritzbox 6360
    funktioniert hat unter g Standard:
    WLAN > Funkkanal die Option Für 300 Mbit/s optimierte Funkkanäle nutzen deaktivieren”
    oder generell auf n+a Standard unter 5 GHZ umschalten.

    Viel Erfolg.

  10. WOW!!!!! Vielen Danke,hat auch soeben bei mir funktioeniert.
    Apple konnte mir am Telefon nicht weiter helfen. Da habe ich ein bisschen gegoogelt und siehe da: ES FUNKTIONIERT!!!!

    Sehr A R M für Aple :-(

  11. Nach tagelangem suchen und Rätseln endlich die Lösung. Es könnte manchmal so einfach sein. Aber wer denkt schon beim Kauf eines iMac an dieses Problem. Liebe Freunde bei Appel da muß aber nach gebessert werden. Mit allen anderen Geräten von Apple (Airbook, iPhone und iPad) gab es in Verbindung mit der Fritzbox 6310 Cable keine Probleme.

    NUR BEIM IMAC. Wollte das Teil schon wieder umtauschen.

  12. Danke der Tipp hat mir auch geholfen, aber ist schon echt übel, dass man die Geschwindigkeit reduzieren muss. :-( Shame on you, Apple!

  13. Hätte es nicht gedacht … War schon völlig genervt und nun geht es ohne Schwierigkeiten …. Peinlich ist schon schon, aber von beiden Seiten … Wieviel Apple Nutzer haben auch ne Fritzbox…

    DAAAAANNNNNNKKKKKEEEE

  14. Auch ich habe mich damals mit meinem nagelneuen IMAC 3.4GHz geärgert; kam dann auf die Idee das 5GHz WLAN zu konfigurieren, und damit geht es ohne Probleme. Ich bin mir sicher, das es anfangs noch funktionierte, und erst nach einem APPLE Update ausfiel. Auch bei mir funktionieren alle anderen Geräte, IPHONE wie WIN Rechner (sorry…), Laptops etc. Habe die Fritzbox 7390. Der Tip klappt auch bei mir; jetzt bekommt mein IMAC wieder eine gültige IP Adresse vom Router, während Airport sich vorher stets eine selbst zugewiesene IP nahm.
    Eine andere Lösung ist übrigens, nicht mit DHCP zu arbeiten, sondern eine feste IP zu vergeben. Dann geht es auch ohne die Deaktivierung der 300er Option im 2.4GHz WLAN.

Leave a Reply

Your email address will not be published. Required fields are marked *